Free Software Foundation!

Join now

Gstreamer

From Free Software Directory
Revision as of 10:50, 12 April 2011 by WikiSysop (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation,
[edit]

Gstreamer

http://gstreamer.freedesktop.org/
'GStreamer' is a streaming media library and set of tools that enable applications to share a common set of plugins for things like video decoding and encoding, audio encoding and decoding, audio and video filters, audio visualisation, Web streaming and anything else that streams in real-time or otherwise. It is modelled after research software worked on at the Oregon Graduate Institute.

Documentation

User FAQ available in HTML format from http://gstreamer.freedesktop.org/data/doc/gstreamer/head/faq/html/; http://gstreamer.freedesktop.org/documentation/ for a complete list of documentation

"IRC irc://irc.freenode.net/gstreamer " IRC Help channel
irc://irc.freenode.net/gstreamer
"IRC irc://irc.freenode.net/gstreamer " IRC development channel
irc://irc.freenode.net/gstreamer


Download

Download External-link-icon.png version 0.10 (stable)
released on 5 December 2005

Categories

Related Projects




Licensing

LicenseVerified byVerified onNotes
LGPLv2orlaterJanet Casey27 August 2003



Leaders and contributors

Contact(s)Role
"Email omega@temple-baptist.org" Erik Walthinsen Maintainer
See the AUTHORS file in the distribution for a complete listContributor


Resources and communication

Audience Resource type URI
Help Mailing List Info/Archive http://lists.sourceforge.net/mailman/listinfo/gstreamer-announce
Bug Tracking Mailing List Info/Archive http://lists.sourceforge.net/mailman/listinfo/gstreamer-bugs
Developer Mailing List Info/Archive http://lists.sourceforge.net/mailman/listinfo/gstreamer-devel


Software prerequisites

Kind Description
Required to build pkgconfig 0.9.0
Required to build autoconf 2.52
Weak prerequisite db2html
Required to use glib2 2.3 or later
Weak prerequisite fig2dev
Required to build automake 1.5
Weak prerequisite xsltproc
Required to build libtool 1.4 or later
Weak prerequisite gtkdoc

This entry (in part or in whole) was last reviewed on 30 November 2007.



Entry











































Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.


Personal tools
Namespaces

Variants
Actions
Navigation
Contribute