Free Software Foundation!

Join now

Guile-gnome

From Free Software Directory
Revision as of 11:40, 12 April 2011 by WikiSysop (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation,
[edit]

Guile-Gnome

http://www.gnu.org/software/guile-gnome/
Guile-Gnome is a Guile wrapper collection for most of the GNOME core libraries.

This packages tries to build the following wrappers: Gobject, Glib, Atk, Pango, Pangocairo, Gdk, Gdk-Pixbuf, Gtk, Libglade, Gnome-Vfs, Corba, Libgnome, Libgnomeui, Libgnomecanvas.

Guile-Gnome makes GNOME accesible from Guile, so it provides a convenient interface for Scheme programmers to develop visual applications. This program includes the Guile-gtk bindings for Gtk+.

Heckert gnu.small.png This is a GNU package:guile-gnome

Download

Download version 2.16.4 (developmental)
released on 7 December 2015

VCS Checkout

Categories

Related Projects




Licensing

LicenseVerified byVerified onNotes
GPLv2orlaterJanet Casey13 February 2004



Leaders and contributors

Contact(s)Role
Andy Wingo Maintainer


Resources and communication

Audience Resource type URI
Developer VCS Repository Webview http://git.savannah.gnu.org/cgit/guile-gnome.git
Developer Download https://ftp.gnu.org/gnu/guile-gnome/
Developer,Support Mailing List Info/Archive http://lists.gnu.org/mailman/listinfo/guile-gtk-general


Software prerequisites

Kind Description
Required to use gtk+-2.0 >= 2.10.0
Required to use libglade-2.0 >= 2.6
Required to use object-2.0
Source requirement Guile-Cairo >= 1.10
Required to use Guile-2.0 or Guile-2.2
Required to use libgnome-2.0 >= 2.16
Required to use gthread-2.0
Required to use Atk >= 1.12
Required to build Autoconf >= 2.61
Required to use libgnomecanvas-2.0 >= 2.14
Required to use gnome-vfs-2.0 >= 2.16.0
Required to use Corba [(and libbonobo-2.0 Orbit-2.0)]
Required to build Automake >= 1.12
Required to use libgnomeui-2.0 >= 2.16.0
Required to use gdk-pixbuf-2.0 >= 2.10.0
Required to use gconf-2.0 >= 2.18
Source requirement Guile-Lib >= 0.2.2
Required to use pango >= 1.14
Required to use gdk-2.0 >= 2.10.0
Required to use glib-2.0 >= 2.10.0
Source requirement G-Wrap >= 1.9.15
Required to use pangocairo >= 1.14

This entry (in part or in whole) was last reviewed on 9 December 2015.



Entry























Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.


Personal tools
Namespaces

Variants
Actions
Navigation
Contribute