Firewall Builder 2

From Free Software Directory
 
Jump to: navigation, search
[edit]

Firewall Builder

http://www.fwbuilder.org/
GUI and policy compilers for various firewall platforms

Firewall Builder consists of a GUI and set of policy compilers for various firewall platforms. It lets users maintain a database of objects and allows policy editing using drag-and-drop. This provides a consistent abstract model and the same GUI for different firewall platforms. Firewall Builder provides XML DTD and C++ API library that support abstraction of network objects and generalized firewall policies. Firewall Builder currently supports iptables, ipfilter, ipfw, and OpenBSD pf.

Documentation

User's Guide is available in PDF format from http://www.fwbuilder.org/UsersGuide.pdf; Firewall Builder Cookbook (collection of examples) is available in HTML format from http://www.fwbuilder.org/archives/cat_cookb.html; FAQ is available from http://www.fwbuilder.org/archives/cat_faq.html


Download

Download version 2.0.8 (stable)
released on 10 July 2005

VCS Checkout

:pserver:anonymous@cvs.fwbuilder.sourceforge.net:/cvsroot/fwbuilder

Categories

Related Projects




Licensing

LicenseVerified byVerified onNotes
GPLv2orlaterJanet Casey17 May 2002



Leaders and contributors

Contact(s)Role
Vadim Kurland Maintainer
Friedhelm Düsterhöft Contributor


Resources and communication

AudienceResource typeURI
Bug TrackingMailing List Info/Archivehttp://lists.sourceforge.net/mailman/listinfo/fwbuilder-bugs
SupportMailing List Info/Archivehttp://lists.sourceforge.net/mailman/listinfo/fwbuilder-discussion
DeveloperVCS Repository Webviewhttp://sourceforge.net/cvs/?group_id=5314
Bug TrackingVCS Repository Webviewhttp://sourceforge.net/tracker/?atid=105314&group_id=5314


Software prerequisites

KindDescription
Required to buildbind devel (8 or 9)
Required to buildlibsigc++ 1.0 or newer
Required to buildlibstdc++ 2.9 or newer
Required to buildlibxml2 2.4.10 or newer
Weak prerequisiteopenssl 0.9.6b or newer
Required to buildlibxslt 1.0.7 or newer
Weak prerequisiteDOC++
Required to buildlibfwbuilder
Required to buildgdk-pixbuf 0.11 or newer
Weak prerequisiteucd-snmp 4.2.3 or later
Required to buildbind (8 or 9)
Required to buildgtk-- 1.2.5 or newer

This entry (in part or in whole) was last reviewed on 12 September 2008.



Entry


















































Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.