Guile-gnome

From Free Software Directory
 
Jump to: navigation, search
[edit]

Guile-Gnome

http://www.gnu.org/software/guile-gnome/
Helps Scheme programmers develop visual applications

Guile-Gnome is a Guile wrapper collection for most of the GNOME core libraries.

This packages tries to build the following wrappers: Gobject, Glib, Atk, Pango, Pangocairo, Gdk, Gdk-Pixbuf, Gtk, Libglade, Gnome-Vfs, Corba, Libgnome, Libgnomeui, Libgnomecanvas.

Guile-Gnome makes GNOME accesible from Guile, so it provides a convenient interface for Scheme programmers to develop visual applications. This program includes the Guile-gtk bindings for Gtk+.

Heckert gnu.small.png This is a GNU package:guile-gnome

Download

Download version 2.16.4 (developmental)
released on 7 December 2015

VCS Checkout

Categories

Related Projects




Licensing

LicenseVerified byVerified onNotes
License:GPLv2orlaterJanet Casey13 February 2004



Leaders and contributors

Contact(s)Role
Andy Wingo Maintainer


Resources and communication

AudienceResource typeURI
DeveloperVCS Repository Webviewhttp://git.savannah.gnu.org/cgit/guile-gnome.git
Developer,SupportMailing List Info/Archivehttp://lists.gnu.org/mailman/listinfo/guile-gtk-general
DeveloperDownloadhttps://ftp.gnu.org/gnu/guile-gnome/


Software prerequisites

KindDescription
Required to usegconf-2.0 >= 2.18
Source requirementGuile-Lib >= 0.2.2
Required to usepango >= 1.14
Required to usegdk-2.0 >= 2.10.0
Required to useglib-2.0 >= 2.10.0
Source requirementG-Wrap >= 1.9.15
Required to usepangocairo >= 1.14
Required to usegtk+-2.0 >= 2.10.0
Required to uselibglade-2.0 >= 2.6
Required to useobject-2.0
Source requirementGuile-Cairo >= 1.10
Required to useGuile-2.0 or Guile-2.2
Required to uselibgnome-2.0 >= 2.16
Required to usegthread-2.0
Required to useAtk >= 1.12
Required to buildAutoconf >= 2.61
Required to uselibgnomecanvas-2.0 >= 2.14
Required to usegnome-vfs-2.0 >= 2.16.0
Required to useCorba [(and libbonobo-2.0 Orbit-2.0)]
Required to buildAutomake >= 1.12
Required to uselibgnomeui-2.0 >= 2.16.0
Required to usegdk-pixbuf-2.0 >= 2.10.0

This entry (in part or in whole) was last reviewed on 9 December 2015.



Entry







































































Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.