Difference between revisions of "Ags"

From Free Software Directory
Jump to: navigation, search
(updated to new major version 2.0.15)
(Redirected page to Gsequencer)
(Tag: New redirect)
 
(5 intermediate revisions by one other user not shown)
Line 1: Line 1:
{{Entry
+
#REDIRECT [[gsequencer]]
|Name=Advanced GTK+ Sequencer
 
|Short description=Audio sequencer
 
|Full description='''Advanced GTK+ Sequencer (AGS) is intended to use for music composition.'''
 
 
 
It features a piano roll, as well a synth, matrix editor, drum machine, soundfont2 player, mixer and an output panel. Further it has LADSPA, DSSI and Lv2 plugin support. It's designed to be highly configurable.  You may add effects to its effect chain; and add or remove audio channels/pads. You may set up a fully functional network of engines, thus there is a link editor for linking audio lines. AGS requires a realtime kernel and [[ALSA_library|ALSA]] support. AGS uses conditional locks to keep several threads in sync that's why you need at least a preemptable kernel.
 
 
 
LADSPA support has been added to version 0.4.2 as well export to WAV.
 
 
 
Version 0.5.x brings you first concurrent audio tree processing support.
 
 
 
Version 0.6.x is dedicated to accessibility. You might control GSequencer by keyboard. As you move to a note it provides you an audible feedback.
 
 
 
Version 0.7.x gives you the benefit of providing the libraries libags, libags-thread, libags-server, libags-audio and libgsequencer. It contains for now an automation editor. Open Sound System (OSS4) and JACK Audio Connection Kit support has been added recently. Now you may configure multiple soundcards. Since 0.7.111 there is MIDI input available. Let you record your MIDI instrument and doing live performance.
 
 
 
Version 0.8.x extended MIDI support to import/export SMF. A built-in envelope editor and additional editing functionality like move/crop selected notes.
 
|Screenshot 1=gsequencer-main-window.png
 
|Screenshot 2=gsequencer-automation-window.png
 
|Homepage URL=http://www.nongnu.org/gsequencer/
 
|Is High Priority Project=No
 
|VCS checkout command=git clone git://git.savannah.nongnu.org/gsequencer.git
 
|Computer languages=C
 
|Documentation note=Documentation included. A reference manual is also here:
 
* [http://nongnu.org/gsequencer/api/libags/ libags]
 
* [http://nongnu.org/gsequencer/api/libags-audio/ libags_audio]
 
* [http://nongnu.org/gsequencer/api/libags-gui/ libags_gui]
 
|Decommissioned or Obsolete=No
 
|Donate=https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=QB95388YSQ4GC
 
|Microblog=https://savannah.nongnu.org/news/atom.php?group=gsequencer
 
|Keywords=sound,audio,sequencer,notation,MIDI,LADSPA,DSSI,Lv2
 
|Version identifier=2.0.15
 
|Version date=2018/09/21
 
|Version status=stable
 
|Version download=https://download.savannah.gnu.org/releases/gsequencer/1.4.x/gsequencer-1.4.32.tar.gz
 
|Version comment=* implemented wave form editor
 
* implemented sound capture ability
 
|Last review by=Bendikker
 
|Last review date=2018/02/19
 
|Submitted date=2013/01/25
 
|Component programs=gsequencer, midi2xml
 
|Paid support=http://krähemann.com
 
|Accepts cryptocurrency donations=No
 
|OpenPGP public key=https://savannah.nongnu.org/people/viewgpg.php?user_id=103808
 
|Test entry=No
 
|Is GNU=No
 
}}
 
{{Project license
 
|License=GPLv3orlater
 
|License copyright=Copyright Joël Krähemann
 
|License verified by=genium
 
|License verified date=2014/07/31
 
}}
 
{{Project license
 
|License=AGPLv3orlater
 
|License copyright=Copyright Joël Krähemann
 
}}
 
{{Project license
 
|License=GFDLv1.3orlater
 
|License copyright=Copyright Joël Krähemann
 
}}
 
{{Person
 
|Real name=Joël Krähemann
 
|Role=maintainer
 
|Email=jkraehemann@gmail.com
 
|Username=Jkraehem
 
}}
 
{{Resource
 
|Resource audience=Debian (Ref) (R)
 
|Resource URL=https://tracker.debian.org/pkg/gsequencer
 
}}
 
{{Resource
 
|Resource audience=Savannah (Ref) (R)
 
|Resource URL=https://savannah.nongnu.org/projects/gsequencer
 
}}
 
{{Resource
 
|Resource audience=Developer
 
|Resource kind=VCS Repository Webview
 
|Resource URL=http://git.savannah.gnu.org/cgit/gsequencer.git
 
}}
 
{{Resource
 
|Resource audience=User
 
|Resource kind=Download
 
|Resource URL=http://download.savannah.gnu.org/releases/gsequencer/
 
}}
 
{{Software category
 
|Audio=editor, mixing, waveform-manipulation
 
|Library=C
 
|Programming-language=C
 
|Runs-on=GNU/Linux
 
|Use=editing, interface, library, mixing, playing
 
|Uitoolkit=gtk
 
|Works-with=audio, xml
 
|Works-with-format=FLAC, ogg-theora
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite description=gtk+-2.0 Gimp toolkit widget library
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite description=libxml2 XML and XPath library
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite description=libuuid-1.2 Unique identifier creation library
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite description=gettext
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite description=libinstpatch-1.0 Sound file container supporting DLS, Soundfont2 and GigaSampler
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite description=libsndfile-1.0 Audio file input and output, supporting FLAC, WAV, ...
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite description=fftw3 Fast fourier transform library
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite description=alsa-lib Advanced linux sound architecture library
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite description=Jack Jack Audio Connection Kit
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite description=Pulseaudio
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Weak prerequisite
 
|Prerequisite description=LADSPA Audio plugin format
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Weak prerequisite
 
|Prerequisite description=DSSI Instrumentation plugin format
 
}}
 
{{Software prerequisite
 
|Prerequisite kind=Weak prerequisite
 
|Prerequisite description=Lv2 Audio plugin format
 
}}
 
{{Featured}}
 
{{Import
 
|Date=2015/08/14
 
|Source=debian
 
|Source link=https://tracker.debian.org/pkg/gsequencer
 
}}
 
{{Import
 
|Date=2017/03/18
 
|Source=fedora
 
|Source link=https://apps.fedoraproject.org/packages/gsequencer
 
}}
 
{{Import
 
|Date=2017/10/07
 
|Source=opensuse
 
|Source link=https://build.opensuse.org/package/show/multimedia:apps/gsequencer
 
}}
 

Latest revision as of 13:29, 14 January 2019

Redirect to:



Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.