Difference between revisions of "Doomsday Engine"

From Free Software Directory
Jump to: navigation, search
(Changed documentation note, personal information and software prerequisites.)
Line 1: Line 1:
 
{{Entry
 
{{Entry
|Name=Doomsday
+
|Name=Doomsday Engine
|Short description=The Doomsday Engine is a greatly enhanced DOOM source port.
+
|Short description=Greatly enhanced Doom source port
|Full description=Doomsday aims to retain the original feel of the games yet leverage modern techniques and technologies, including hardware accelerated 3D graphics and client/server networking. A lot of emphasis is placed on good-looking graphics.
+
|Full description='''Doomsday Engine aims to retain the original feel of the games yet leverage modern techniques and technologies, including hardware accelerated 3D graphics and client/server networking.'''
 +
 
 +
A lot of emphasis is placed on good-looking graphics.
 
|Homepage URL=http://www.dengine.net/
 
|Homepage URL=http://www.dengine.net/
 
|User level=beginner
 
|User level=beginner
|Documentation note=We could tell the Doomsday team not to include FMOD Ex, since it might be non-free.
+
|Computer languages=C
 
|Related projects=Freedoom, PrBoom
 
|Related projects=Freedoom, PrBoom
 
|Version identifier=1.14.5
 
|Version identifier=1.14.5
Line 11: Line 13:
 
|Version status=stable
 
|Version status=stable
 
|Version download=https://github.com/skyjake/Doomsday-Engine/archive/release-1.14.5.tar.gz
 
|Version download=https://github.com/skyjake/Doomsday-Engine/archive/release-1.14.5.tar.gz
 +
|Version comment=We could tell the Doomsday team not to include FMOD Ex, since it might be non-free.
 +
|Last review by=Calinou
 +
|Last review date=2014/12/13
 
|Submitted by=ADFENO
 
|Submitted by=ADFENO
 
|Submitted date=2014/12/13
 
|Submitted date=2014/12/13
Line 18: Line 23:
 
{{Project license
 
{{Project license
 
|License=GPLv2orlater
 
|License=GPLv2orlater
|License copyright=Copyright: 1999-2011 Jaakko Keränen <jaakko.keranen@iki.fi>
+
|License copyright=© 1999-2011 Jaakko Keränen <jaakko.keranen@iki.fi>
 +
|License verified by=Calinou
 +
|License verified date=2014/12/13
 
}}
 
}}
 
{{Person
 
{{Person
Line 28: Line 35:
 
{{Software category
 
{{Software category
 
|Game=action, shoot-em-up
 
|Game=action, shoot-em-up
|Graphics=2d, 3d
 
 
|Interface=x-window-system
 
|Interface=x-window-system
 +
|Programming-language=C
 +
|Runs-on=Windows, BSD, OS X
 
|Use=gameplaying
 
|Use=gameplaying
 
}}
 
}}
Line 38: Line 46:
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to build
 
|Prerequisite kind=Required to build
|Prerequisite description= python
+
|Prerequisite description=python
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
Line 46: Line 54:
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Weak prerequisite
 
|Prerequisite kind=Weak prerequisite
|Prerequisite description= qt-creator
+
|Prerequisite description=qt-creator
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
Line 54: Line 62:
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to build
 
|Prerequisite kind=Required to build
|Prerequisite description= libsdl-mixer1.2-dev
+
|Prerequisite description=libsdl-mixer1.2-dev
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
Line 66: Line 74:
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to build
 
|Prerequisite kind=Required to build
|Prerequisite description=libopenal-dev | libfluidsynth-dev | libfmod (already in version's source code)
+
|Prerequisite description=libopenal-dev
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
Line 110: Line 118:
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=libgl1-mesa-glx | libgl1
+
|Prerequisite description=libgl1-mesa-glx
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite

Revision as of 12:24, 13 December 2014

[edit]

Doomsday Engine

http://www.dengine.net/
Greatly enhanced Doom source port

Doomsday Engine aims to retain the original feel of the games yet leverage modern techniques and technologies, including hardware accelerated 3D graphics and client/server networking.

A lot of emphasis is placed on good-looking graphics.

Related Projects





Licensing

License

Verified by

Verified on

Notes

Verified by

Calinou

Verified on

13 December 2014




Leaders and contributors

Contact(s)Role
Jaakko Keränen Main developer


Resources and communication

AudienceResource typeURI
Debian (Ref) (R)https://tracker.debian.org/pkg/deutex
Debian (Ref) (R)https://tracker.debian.org/pkg/doomsday


Software prerequisites

KindDescription
Required to buildbuild-essential
Required to uselibc6 (>= 2.4)
Required to usepython-wxgtk2.8
Required to buildlibx11-dev
Required to uselibtinfo5
Required to buildlibsdl1.2-dev
Required to uselibqtcore4 (>= 4:4.8.0)
Required to buildpython
Required to uselibfluidsynth1
Required to uselibncurses5 (>= 5.5-5~)
Required to buildlibxext-dev
Required to uselibx11-6
Required to buildlibpng-dev
Required to uselibqtgui4 (>= 4:4.7.0~beta1)
Required to buildqt4-qmake
Required to uselibgcc1 (>= 1:4.1.1)
Required to buildlibgl1-mesa-dev
Required to uselibxrandr2 (>= 4.3)
Required to buildlibopenal-dev
Required to uselibsdl-mixer1.2
Weak prerequisiteqt-creator
Required to uselibgl1-mesa-glx
Required to buildlibglu1-mesa-dev
Required to uselibxxf86vm1
Required to buildzlib1g-dev
Required to uselibsdl1.2debian (>= 1.2.10-1)
Required to buildlibltdl3-dev
Required to uselibqt4-network (>= 4:4.6.1)
Required to buildlibxxf86vm-dev
Required to usezlib1g (>= 1:1.1.4)
Required to buildlibncurses5-dev
Required to uselibstdc++6 (>= 4.6)
Required to buildlibsdl-mixer1.2-dev
Required to uselibqt4-opengl (>= 4:4.7.0~beta1)

This entry (in part or in whole) was last reviewed on 13 February 2018.



Entry















"Main developer" is not in the list (Maintainer, Contributor, Developer, Sponsor, Unknown) of allowed values for the "Role" property.











































































Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.