Foomatic

From Free Software Directory
Revision as of 08:54, 12 April 2011 by WikiSysop (talk | contribs)$7

(diff) ← Older revision | Approved revision (diff) | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
[edit]

Foomatic

https://wiki.linuxfoundation.org/openprinting/database/foomatic
Printer/driver database of Linuxprinting.org

Foomatic is the printer/driver database of Linuxprinting.org. The XML-based system integrates free software printer drivers with all common spoolers (CUPS, LPRng, LPD, GNUlpr, PPR, PDQ, CPS, etc.) in UNIX. It generates printer/driver description files which, together with spooler-specific filter scripts, allow easy setup of print queues with access to all driver options. Foomatic ships with every major distro and its Web site is used as a reference by vendors. It is an up-to-date and distribution-independent repository of printer and driver data, scripts, and utilities, accompanied by the wealth of knowledge, tips and tricks, solutions, and enlightenment provided by its newsgroups.

Documentation

User README included; User guide included (see the USAGE file); User tutorials available in HTML format from http://www.linuxprinting.org/linux-kongress-tutorial-2002.html


Download

Download version 4.0-20170225 (stable)
released on 25 February 2017

Categories

Related Projects




Licensing

LicenseVerified byVerified onNotes
License:GPLv2orlaterJanet Casey28 January 2003



Leaders and contributors

Contact(s)Role
Grant Taylor Maintainer
Till Kamppeter Maintainer


Resources and communication

AudienceResource typeURI
DeveloperE-mailmailto:foomatic-devel@linuxprinting.org


Software prerequisites

KindDescription
Weak prerequisiteespgs; See also http://www.linuxprinting.org/database.html for a list of compatible printers and drivers
Weak prerequisitepdq
Required to usePerl
Weak prerequisitelpd
Weak prerequisitecps
Required to usemake
Weak prerequisitelprng
Weak prerequisitexpp
Weak prerequisitegnulpr
Weak prerequisitekprinter
Weak prerequisitecups
Required to usewget *or* cURL
Weak prerequisitegpr
Weak prerequisiteppr
Required to uselibxml 2.x

This entry (in part or in whole) was last reviewed on 26 February 2017.



Entry
















































Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.