Difference between revisions of "Gajim"

From Free Software Directory
Jump to: navigation, search
(homepage)
m (https links)
Line 7: Line 7:
 
|VCS checkout command=hg clone http://hg.gajim.org/gajim gajim
 
|VCS checkout command=hg clone http://hg.gajim.org/gajim gajim
 
|Computer languages=Python
 
|Computer languages=Python
|Documentation note=[http://gajim.org/docs.php Documentation for users and developers]
+
|Documentation note=[https://gajim.org/docs.php Documentation for users and developers]
 
|Related projects=nbxmpp
 
|Related projects=nbxmpp
 
|Keywords=client,Python,GTK,Jabber,XMPP,nbxmpp,xmpppy,PyGTK
 
|Keywords=client,Python,GTK,Jabber,XMPP,nbxmpp,xmpppy,PyGTK
Line 13: Line 13:
 
|Version date=2013/05/25
 
|Version date=2013/05/25
 
|Version status=stable
 
|Version status=stable
|Version download=http://gajim.org/downloads/0.15/gajim-0.15.4.tar.bz2
+
|Version download=https://gajim.org/downloads/0.15/gajim-0.15.4.tar.bz2
 
|Version comment=* Fix usage of OTR plugin
 
|Version comment=* Fix usage of OTR plugin
 
   * Fix connection to non-SSL server
 
   * Fix connection to non-SSL server

Revision as of 17:15, 22 November 2013

[edit]

Gajim

https://gajim.org/
A full featured and easy-to-use Jabber/XMPP client

Gajim is a Jabber/XMPP client written in PyGTK. Gajim works nicely with GNOME, but does not require it to run.

Documentation

User and developer wiki

Plugins

Related Projects


Extensions, plug-ins, or add-ons for this program

FarstreamAudio/Video communications framework: Python bindingshttp://freedesktop.org/wiki/Software/Farstream/


Licensing

LicenseVerified byVerified onNotes
License:GPLv3Kelly Hopkins25 January 2010



Leaders and contributors

Contact(s)Role
Yann Le Boulanger Owner
Denis Fomin Maintainer


Resources and communication

AudienceResource typeURI
Developer,SupportE-mailmailto:gajim-devel@gajim.org
DeveloperVCS Repository Webviewhttps://dev.gajim.org/gajim/gajim/tree/master
Bug TrackingVCS Repository Webviewhttps://dev.gajim.org/gajim/gajim/issues
Bug ReportingVCS Repository Webviewhttps://dev.gajim.org/gajim/gajim/issues/new


Software prerequisites

KindDescription
Weak prerequisitegnomepythonextras
Required to usePython 2.5-2.7
Required to buildlibgtk2.0-dev
Required to usePyGTK 2.22 or higher
Required to buildpython-dev
Required to usepython-nbxmpp
Required to buildpython-gtk2-dev
Required to buildintltool (>= 0.40.1)
Weak prerequisitepython-gnupginterface

This entry (in part or in whole) was last reviewed on 12 May 2017.



Entry












"Owner" is not in the list (Maintainer, Contributor, Developer, Sponsor, Unknown) of allowed values for the "Role" property.











"Bug Reporting" is not in the list (General, Help, Bug Tracking, Support, Developer) of allowed values for the "Resource audience" property.


























Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.