Difference between revisions of "Gajim"

From Free Software Directory
Jump to: navigation, search
m (https links)
(updated to 0.16.7)
Line 1: Line 1:
 
{{Entry
 
{{Entry
 
|Name=Gajim
 
|Name=Gajim
|Short description=Jabber/XMPP client written in PyGTK
+
|Short description=A full featured and easy-to-use Jabber/XMPP client
|Full description=Gajim is a Jabber/XMPP client written in PyGTK. The goal of Gajim project is to provide a full featured and easy to use XMPP client.  Gajim works nicely with GNOME, but does not require it to run.
+
|Full description=Gajim is a Jabber/XMPP client written in PyGTK. Gajim works nicely with GNOME, but does not require it to run.
 
|Homepage URL=https://gajim.org/
 
|Homepage URL=https://gajim.org/
 
|User level=intermediate
 
|User level=intermediate
|VCS checkout command=hg clone http://hg.gajim.org/gajim gajim
+
|VCS checkout command=git clone https://dev.gajim.org/gajim/gajim.git
 
|Computer languages=Python
 
|Computer languages=Python
|Documentation note=[https://gajim.org/docs.php Documentation for users and developers]
+
|Documentation note=[https://dev.gajim.org/gajim/gajim/wikis/home User and developer wiki]
 +
[https://dev.gajim.org/gajim/gajim-plugins Plugins]
 
|Related projects=nbxmpp
 
|Related projects=nbxmpp
 
|Keywords=client,Python,GTK,Jabber,XMPP,nbxmpp,xmpppy,PyGTK
 
|Keywords=client,Python,GTK,Jabber,XMPP,nbxmpp,xmpppy,PyGTK
|Version identifier=0.15.4
+
|Version identifier=0.16.7
|Version date=2013/05/25
+
|Version date=2017/01/30
 
|Version status=stable
 
|Version status=stable
|Version download=https://gajim.org/downloads/0.15/gajim-0.15.4.tar.bz2
+
|Version download=https://gajim.org/downloads.php
|Version comment=* Fix usage of OTR plugin
+
|Last review by=David Seaward
  * Fix connection to non-SSL server
+
|Last review date=2017/05/12
  * Fix receiving GPG-encrypted messages while offline.
 
|Last review by=Janet Casey
 
|Last review date=2010-01-25
 
|Submitted by=Database conversion
 
 
|Submitted date=2011-04-01
 
|Submitted date=2011-04-01
|Status=
 
 
|Is GNU=No
 
|Is GNU=No
 
|License verified date=2010-01-25
 
|License verified date=2010-01-25
Line 29: Line 25:
 
|License verified by=Kelly Hopkins
 
|License verified by=Kelly Hopkins
 
|License verified date=2010-01-25
 
|License verified date=2010-01-25
}}
+
|License note=https://dev.gajim.org/gajim/gajim/blob/master/COPYING
{{Project license
 
|License=GPLv3
 
|License verified by=Kelly Hopkins
 
|License verified date=2010-01-25
 
 
}}
 
}}
 
{{Person
 
{{Person
Line 39: Line 31:
 
|Role=Owner
 
|Role=Owner
 
|Email=asterix@lagaule.org
 
|Email=asterix@lagaule.org
|Resource URL=
 
 
}}
 
}}
 
{{Person
 
{{Person
Line 45: Line 36:
 
|Role=Maintainer
 
|Role=Maintainer
 
|Email=fominde@gmail.com
 
|Email=fominde@gmail.com
|Resource URL=
 
 
}}
 
}}
 
{{Resource
 
{{Resource
 
|Resource audience=Developer
 
|Resource audience=Developer
 
|Resource kind=VCS Repository Webview
 
|Resource kind=VCS Repository Webview
|Resource URL=https://trac.gajim.org/browser/
+
|Resource URL=https://dev.gajim.org/gajim/gajim/tree/master
 
}}
 
}}
 
{{Resource
 
{{Resource
 
|Resource audience=Bug Tracking
 
|Resource audience=Bug Tracking
 
|Resource kind=VCS Repository Webview
 
|Resource kind=VCS Repository Webview
|Resource URL=https://trac.gajim.org/report
+
|Resource URL=https://dev.gajim.org/gajim/gajim/issues
 
}}
 
}}
 
{{Resource
 
{{Resource
Line 65: Line 55:
 
|Resource audience=Bug Reporting
 
|Resource audience=Bug Reporting
 
|Resource kind=VCS Repository Webview
 
|Resource kind=VCS Repository Webview
|Resource URL=https://trac.gajim.org/newticket
+
|Resource URL=https://dev.gajim.org/gajim/gajim/issues/new
 
}}
 
}}
 
{{Software category
 
{{Software category
Line 74: Line 64:
 
|Programming-language=python
 
|Programming-language=python
 
|Protocol=voip, zeroconf, xmpp
 
|Protocol=voip, zeroconf, xmpp
 +
|Runs-on=Windows, GNU/Linux
 
|Use=live-communications
 
|Use=live-communications
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=python-glade2
+
|Prerequisite description=Python 2.5-2.7
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=python 2.4 or later
+
|Prerequisite description=PyGTK 2.22 or higher
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=python-gtk2
+
|Prerequisite description=python-nbxmpp
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
Line 99: Line 90:
 
|Prerequisite kind=Required to build
 
|Prerequisite kind=Required to build
 
|Prerequisite description=python-gtk2-dev
 
|Prerequisite description=python-gtk2-dev
 +
}}
 +
{{Software prerequisite
 +
|Prerequisite kind=Required to build
 +
|Prerequisite description=intltool (>= 0.40.1)
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite

Revision as of 10:13, 12 May 2017

[edit]

Gajim

https://gajim.org/
A full featured and easy-to-use Jabber/XMPP client

Gajim is a Jabber/XMPP client written in PyGTK. Gajim works nicely with GNOME, but does not require it to run.

Documentation

User and developer wiki

Plugins

Related Projects



Extensions, plug-ins, or add-ons for this program

FarstreamAudio/Video communications framework: Python bindingshttp://freedesktop.org/wiki/Software/Farstream/


Licensing

License

Verified by

Verified on

Notes

Verified by

Kelly Hopkins

Verified on

25 January 2010




Leaders and contributors

Contact(s)Role
Yann Le Boulanger Owner
Denis Fomin Maintainer


Resources and communication

AudienceResource typeURI
Developer,SupportE-mailmailto:gajim-devel@gajim.org
DeveloperVCS Repository Webviewhttps://dev.gajim.org/gajim/gajim/tree/master
Bug TrackingVCS Repository Webviewhttps://dev.gajim.org/gajim/gajim/issues
Bug ReportingVCS Repository Webviewhttps://dev.gajim.org/gajim/gajim/issues/new
Debian (Ref)https://tracker.debian.org/pkg/gajim


Software prerequisites

KindDescription
Required to buildlibgtk2.0-dev
Required to usePyGTK 2.22 or higher
Required to buildpython-dev
Required to usepython-nbxmpp
Required to buildpython-gtk2-dev
Required to buildintltool (>= 0.40.1)
Weak prerequisitepython-gnupginterface
Weak prerequisitegnomepythonextras
Required to usePython 2.5-2.7

This entry (in part or in whole) was last reviewed on 14 February 2018.



Entry







Property "Submitted by" (as page type) with input value "{{{Submitted by}}}" contains invalid characters or is incomplete and therefore can cause unexpected results during a query or annotation process.









"Owner" is not in the list (Maintainer, Contributor, Developer, Sponsor, Unknown) of allowed values for the "Role" property.











"Bug Reporting" is not in the list (General, Help, Bug Tracking, Support, Developer) of allowed values for the "Resource audience" property.



























Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.