Difference between revisions of "Gedcom4j"

From Free Software Directory
Jump to: navigation, search
(Updated entry to v3.0.0)
Line 9: Line 9:
 
|Computer languages=Java
 
|Computer languages=Java
 
|Keywords=genealogy, gedcom, library
 
|Keywords=genealogy, gedcom, library
|Version identifier=v3.0.0
+
|Version identifier=v3.2.0
|Version date=2016/07/15
+
|Version date=2016/09/04
 
|Version status=stable
 
|Version status=stable
 
|Version download=http://gedcom4j.org/main/sites/default/files/gedcom4j-3.0.0.jar
 
|Version download=http://gedcom4j.org/main/sites/default/files/gedcom4j-3.0.0.jar
|Version comment=v3.0.0 is a major release. Most existing code using earlier versions of gedcom4j will need significant modification, primarily around the object model, since it now implements the Javabeans spec...so you'll need to switch to getters and setters. Full details can be found in the release notes on the download page at http://gedcom4j.org/downloads
+
|Version comment=v3.2.0 is a minor release with a number of backward-compatible API changes for bug fixes and enhancements.
 
|Submitted by=frizbog
 
|Submitted by=frizbog
|Submitted date=2016/07/19
+
|Submitted date=2016/09/10
 
|Status=
 
|Status=
 
|Is GNU=No
 
|Is GNU=No
Line 45: Line 45:
 
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
 
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
 
OTHER DEALINGS IN THE SOFTWARE.
 
OTHER DEALINGS IN THE SOFTWARE.
 
 
}}
 
}}
 
{{Person
 
{{Person
Line 63: Line 62:
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=Java 1.6 or later
+
|Prerequisite description=Java 1.7 or later
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to build
 
|Prerequisite kind=Required to build
|Prerequisite description=Java 1.6 or later, Maven
+
|Prerequisite description=Java 1.7 or later, Maven
 
}}
 
}}
 
{{Featured}}
 
{{Featured}}

Revision as of 20:41, 10 September 2016


[edit]

gedcom4j

http://gedcom4j.org
Java library for GEDCOM parsing and writing

gedcom4j is a Java library for loading (parsing) and saving GEDCOM 5.5 or 5.5.1 files to/from a Java object hierarchy, which can be manipulated by your code as you see fit.

Please note that gedcom4j is not an application. It is a library (jar file) that can parse, manipulate, and write GEDCOM data from your own Java programs.





Licensing

License

Verified by

Verified on

Notes




Leaders and contributors

Contact(s)Role
Matthew Harrah (Frizbog)Project Owner


Resources and communication

Software prerequisites

KindDescription
Required to useJava 1.7 or later
Required to buildJava 1.7 or later, Maven




Entry





"MIT License" is not in the list (ACEL, AFL-3.0, AGPL-1.0, AGPL-1.0-or-later, AGPL-3.0, AGPL-3.0-or-later, AGPL-3.0-or-later-with-exception, AGPL-3.0-with-exception, AGPLv1orlater, AGPLv3, ...) of allowed values for the "License" property.




"Project Owner" is not in the list (Maintainer, Contributor, Developer, Sponsor, Unknown) of allowed values for the "Role" property.












Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.