Difference between revisions of "Genius"

From Free Software Directory
Jump to: navigation, search
(genius-1.0.25)
m (gnome link)
 
Line 14: Line 14:
 
|Version date=2020/03/06
 
|Version date=2020/03/06
 
|Version status=stable
 
|Version status=stable
|Version download=http://ftp.5z.com/pub/genius/genius-1.0.25.tar.xz
+
|Version download=https://download.gnome.org/sources/genius/1.0/genius-1.0.25.tar.xz
 
|Last review by=Genium
 
|Last review by=Genium
 
|Last review date=2020/03/06
 
|Last review date=2020/03/06
Line 20: Line 20:
 
|User level=none
 
|User level=none
 
|Accepts cryptocurrency donations=No
 
|Accepts cryptocurrency donations=No
 +
|Checksum=https://download.gnome.org/sources/genius/1.0/genius-1.0.25.sha256sum
 
|Test entry=No
 
|Test entry=No
 
|Is GNU=No
 
|Is GNU=No

Latest revision as of 09:20, 6 March 2020


[edit]

Genius

http://www.jirka.org/genius.html
Arbitrary precision integer and multiple precision floating point calculator

'Genius' is an arbitrary precision integer and multiple precision floating point calculator. It can deal with rational numbers and complex numbers. It has matrix support as well. It uses the gmp library so it is very fast for calculations of large numbers. It has a command line and a GNOME interface.





Licensing

License

Verified by

Verified on

Notes

Verified by

Genium

Verified on

6 March 2020




Leaders and contributors

Contact(s)Role
George Lebl Maintainer


Resources and communication

AudienceResource typeURI
Ruby (Ref)https://rubygems.org/gems/genius
Debian (Ref)https://tracker.debian.org/pkg/genius
Python (Ref)https://pypi.org/project/genius
DeveloperVCS Repository Webviewhttps://gitlab.gnome.org/GNOME/genius/
Bug Tracking,Developer,SupportE-mailmailto:jirka@5z.com
DeveloperBug Trackinghttps://gitlab.gnome.org/GNOME/genius/issues
DeveloperDownloadhttps://download.gnome.org/sources/genius/


Software prerequisites

KindDescription
Required to useglib 2.41.1
Required to usempfr
Weak prerequisiteamtk
Required to usegmp
Required to useLex
Weak prerequisitegtk+ 3.21.4
Required to useyacc
Weak prerequisitegtksourceview4 3.99.7
Weak prerequisitevte 2.91




Entry










"Python (Ref)" is not in the list (General, Help, Bug Tracking, Support, Developer) of allowed values for the "Resource audience" property.


"Ruby (Ref)" is not in the list (General, Help, Bug Tracking, Support, Developer) of allowed values for the "Resource audience" property.


"Debian (Ref)" is not in the list (General, Help, Bug Tracking, Support, Developer) of allowed values for the "Resource audience" property.


































Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.