Gnunet

From Free Software Directory
Revision as of 15:12, 11 January 2013 by Johns (talk | contribs)$7

Jump to: navigation, search
[edit]

GNUnet

https://gnunet.org/
Anonymous peer-to-peer file-sharing

GNUnet is a framework for secure peer-to-peer networking that does not use any centralized or otherwise trusted services. Its high-level goal is to provide a strong free software foundation for a global network that provides security and privacy.

GNUnet started with an idea for anonymous censorship-resistant file-sharing, but has grown to incorporate other applications as well as many generic building blocks for secure networking applications. In particular, GNUnet now includes the GNU Name System, a privacy-preserving, decentralized public key infrastructure.

Documentation

User reference available in HTML format from https://gnunet.org/book.
"IRC [irc:irc.freenode.net/gnunet irc:irc.freenode.net/gnunet] " IRC Help channel
[irc:irc.freenode.net/gnunet irc:irc.freenode.net/gnunet]

"IRC [irc:irc.freenode.net/gnunet irc:irc.freenode.net/gnunet] " IRC development channel
[irc:irc.freenode.net/gnunet irc:irc.freenode.net/gnunet]



This package is listed in the following Collections:


Licensing

LicenseVerified byVerified onNotes
GPLv3orlaterAndrew Engelbrecht15 September 2012



Leaders and contributors

Contact(s)Role
Christian Grothoff Maintainer


Resources and communication

AudienceResource typeURI
DeveloperBug Trackinghttps://gnunet.org/bugs/
SupportE-mailmailto:help-gnunet@gnu.org
HelpE-mailmailto:info-gnunet@gnu.org
DebianDownloadhttp://ftp.debian.org/debian/pool/main/g/gnunet/
DeveloperVCS Repository Webviewhttps://gnunet.org/git/
Bug TrackingE-mailmailto:bug-gnunet@gnu.org
DeveloperDownloadhttp://ftpmirror.gnu.org/gnunet/
DeveloperE-mailmailto:gnunet-developers@gnu.org


Software prerequisites

KindDescription
Required to buildlibcurl
Weak prerequisitelibgcrypt
Required to buildgcc
{{{Prerequisite description}}}
Weak prerequisitetdb
Required to buildmake
Weak prerequisitemysql
Required to buildautomake
Source requirementlibextractor
Required to buildautoconf
Required to uselibextractor
Required to buildlibmicrohttpd
Weak prerequisiteopenssl
Required to buildlibtool

This entry (in part or in whole) was last reviewed on 13 January 2017.



Entry
























































"{{{Prerequisite kind}}}" is not in the list (Required to use, Required to build, Source requirement, Weak prerequisite) of allowed values for the "Prerequisite kind" property.






Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.