Difference between revisions of "Guile-gnome"

From Free Software Directory
Jump to: navigation, search
m (formatting)
(added a category + updated resource info)
 
(13 intermediate revisions by 5 users not shown)
Line 1: Line 1:
 
{{Entry
 
{{Entry
 
|Name=Guile-Gnome
 
|Name=Guile-Gnome
|Short description=Helps Scheme programmers develop visual applications
+
|Short description=Helps Scheme programmers develop visual applications.
|Full description='''Guile-Gnome''' is a [[Guile]] wrapper collection for most of the [[GNOME]] core libraries.
+
|Full description='''Guile-Gnome''' is a [[Guile]] wrapper collection for some of the [[GNOME]] core libraries.
  
This packages tries to build the following wrappers:  Gobject, Glib, Atk, Pango, Pangocairo, Gdk, Gdk-Pixbuf, [[Guile-gtk|Gtk]], Libglade, Gnome-Vfs, Corba, Libgnome, Libgnomeui, Libgnomecanvas.
+
This package tries to build the following wrappers:  Gobject, Glib, Atk, Pango, Pangocairo, Gdk, Gdk-Pixbuf, Gtk, Libglade, Libgnome, Libgnomeui, Libgnomecanvas.
  
Guile-Gnome makes GNOME accesible from Guile, so it provides a convenient interface for Scheme programmers to develop visual applications. This program includes the [[Guile-gtk]] bindings for [[Gtk+]].
+
Guile-Gnome makes GNOME accesible from Guile, so it provides a convenient interface for Scheme programmers to develop visual applications.
|Homepage URL=http://www.gnu.org/software/guile-gnome/
+
|Homepage URL=https://www.gnu.org/software/guile-gnome/
|User level=advanced
+
|Is High Priority Project=No
 
|VCS checkout command=git clone git://git.savannah.gnu.org/guile-gnome.git
 
|VCS checkout command=git clone git://git.savannah.gnu.org/guile-gnome.git
|Computer languages=C,Scheme
+
|Documentation note=https://www.gnu.org/software/guile-gnome/documentation.html
|Related projects=DrScheme,Guile
+
|Decommissioned or Obsolete=No
 +
|Donate=https://my.fsf.org/donate/
 +
|IRC general=irc://irc.freenode.net/#guile
 +
|Related projects=gnustandards,Guile,Gnome
 
|Keywords=GTK+,GUI,Gnome,development,interface,graphical,scheme,guile
 
|Keywords=GTK+,GUI,Gnome,development,interface,graphical,scheme,guile
|Version identifier=2.16.3
+
|Version identifier=2.16.5
|Version date=2015/07/27
+
|Version date=2017/06/03
|Version status=developmental
+
|Version status=stable
|Version download=http://git.savannah.gnu.org/cgit/guile-gnome.git/snapshot/guile-gnome-2.16.3.tar.gz
+
|Version download=https://ftp.gnu.org/gnu/guile-gnome/guile-gnome-platform/guile-gnome-platform-2.16.5.tar.gz
 
|Last review by=Genium
 
|Last review by=Genium
|Last review date=2015/09/08
+
|Last review date=2021/01/30
 
|Submitted by=Database conversion
 
|Submitted by=Database conversion
|Submitted date=2011-04-01
+
|Submitted date=2011/04/01
|Status=
+
|User level=advanced
|Is GNU=Yes
+
|Paid support=https://www.fsf.org/resources/service/
|GNU package identifier=guile-gnome
+
|Accepts cryptocurrency donations=Yes
|License verified date=2004-02-13
+
|OpenPGP signature=https://ftp.gnu.org/gnu/guile-gnome/guile-gnome-platform/guile-gnome-platform-2.16.5.tar.gz.sig
 +
|Test entry=No
 
}}
 
}}
 
{{Project license
 
{{Project license
Line 30: Line 34:
 
|License verified by=Janet Casey
 
|License verified by=Janet Casey
 
|License verified date=2004-02-13
 
|License verified date=2004-02-13
}}
 
{{Person
 
|Real name=Andy Wingo
 
|Role=Maintainer
 
|Email=apwingo@eos.ncsu.edu
 
|Resource URL=
 
}}
 
{{Resource
 
|Resource audience=Developer
 
|Resource kind=VCS Repository Webview
 
|Resource URL=http://git.savannah.gnu.org/cgit/guile-gnome.git
 
}}
 
{{Resource
 
|Resource audience=Developer,Support
 
|Resource kind=Mailing List Info/Archive
 
|Resource URL=http://lists.gnu.org/mailman/listinfo/guile-gtk-general
 
}}
 
{{Resource
 
|Resource audience=Developer
 
|Resource kind=Download
 
|Resource URL=https://ftp.gnu.org/gnu/guile-gnome/
 
 
}}
 
}}
 
{{Software category
 
{{Software category
 
|Interface=command-line
 
|Interface=command-line
|Programming-language=scheme
+
|Programming-language=C, python, scheme
 +
|Runs-on=BSD, GNU/Linux
 
|Software-development=programming-language
 
|Software-development=programming-language
 
|Use=software-development
 
|Use=software-development
Line 60: Line 44:
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=gtk+-2.0 >= 2.10.0
+
|Prerequisite description=[[gtk+]] -2.0 >= 2.10.0
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=Guile-2.0 or Guile-2.2
+
|Prerequisite description=[[Guile]] -2.0 or Guile-2.2
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to build
 
|Prerequisite kind=Required to build
|Prerequisite description=Autoconf >= 2.61
+
|Prerequisite description=[[Autoconf]] >= 2.61
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to build
 
|Prerequisite kind=Required to build
|Prerequisite description=Automake >= 1.12
+
|Prerequisite description=[[Automake]] >= 1.12
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Source requirement
 
|Prerequisite kind=Source requirement
|Prerequisite description=Guile-Lib >= 0.2.2
+
|Prerequisite description=[[Guile-Lib]] >= 0.2.2
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Source requirement
 
|Prerequisite kind=Source requirement
|Prerequisite description=G-Wrap >= 1.9.15
+
|Prerequisite description=[[G-Wrap]] >= 1.9.15
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Source requirement
 
|Prerequisite kind=Source requirement
|Prerequisite description=Guile-Cairo >= 1.10
+
|Prerequisite description=[[Guile-Cairo]] >= 1.10
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=Atk >= 1.12
+
|Prerequisite description=[[Atk]] >= 1.12
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=Corba [(and libbonobo-2.0 Orbit-2.0)]
+
|Prerequisite description=[[Corba]] [(and [[libbonobo]] -2.0 [[Orbit]] -2.0)]
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=gconf-2.0 >= 2.18
+
|Prerequisite description=[[gconf]] -2.0 >= 2.18
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=glib-2.0 >= 2.10.0
+
|Prerequisite description=[[glib]] -2.0 >= 2.10.0
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=object-2.0
+
|Prerequisite description=[[object]] -2.0
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=gthread-2.0
+
|Prerequisite description=[[gthread]] -2.0
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=gnome-vfs-2.0 >= 2.16.0
+
|Prerequisite description=[[gnome-vfs]] -2.0 >= 2.16.0
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=gdk-pixbuf-2.0 >= 2.10.0
+
|Prerequisite description=[[gdk-pixbuf]] -2.0 >= 2.10.0
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=gdk-2.0 >= 2.10.0
+
|Prerequisite description=[[gdk]] -2.0 >= 2.10.0
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=libglade-2.0 >= 2.6
+
|Prerequisite description=[[libglade]] -2.0 >= 2.6
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=libgnome-2.0 >= 2.16
+
|Prerequisite description=[[libgnome]] -2.0 >= 2.16
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=libgnomecanvas-2.0 >= 2.14
+
|Prerequisite description=[[libgnomecanvas]] -2.0 >= 2.14
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=libgnomeui-2.0 >= 2.16.0
+
|Prerequisite description=[[libgnomeui]] -2.0 >= 2.16.0
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=pango >= 1.14
+
|Prerequisite description=[[pango]] >= 1.14
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
 
|Prerequisite kind=Required to use
 
|Prerequisite kind=Required to use
|Prerequisite description=pangocairo >= 1.14
+
|Prerequisite description=[[pangocairo]] >= 1.14
 +
}}
 +
{{Person
 +
|Real name=Andy Wingo
 +
|Role=Maintainer
 +
|Email=wingo@pobox.com
 +
}}
 +
{{Person
 +
|Real name=David Pirotte
 +
|Role=Co-Maintainer
 +
|Email=david@altosw.be
 +
}}
 +
{{Resource
 +
|Resource audience=Savannah
 +
|Resource kind=Developer
 +
|Resource URL=https://savannah.gnu.org/projects/guile-gnome/
 +
}}
 +
{{Resource
 +
|Resource kind=VCS Repository Webview
 +
|Resource URL=https://git.savannah.gnu.org/cgit/guile-gnome.git/
 +
}}
 +
{{Resource
 +
|Resource kind=Mailing List
 +
|Resource URL=https://lists.gnu.org/mailman/listinfo/guile-gtk-general/
 +
}}
 +
{{Resource
 +
|Resource audience=FTP
 +
|Resource kind=Mailing List
 +
|Resource URL=https://ftpmirror.gnu.org/guile-gnome/
 +
}}
 +
{{Resource
 +
|Resource audience=FTP
 +
|Resource kind=Download
 +
|Resource URL=https://ftp.gnu.org/gnu/guile-gnome/
 +
}}
 +
{{Resource
 +
|Resource audience=Wikidata
 +
|Resource kind=General
 +
|Resource URL=https://www.wikidata.org/wiki/Q105124253
 +
}}
 +
{{Resource
 +
|Resource audience=Debian
 +
|Resource kind=Developer
 +
|Resource URL=https://tracker.debian.org/pkg/guile-gnome-platform
 
}}
 
}}
 
{{Featured}}
 
{{Featured}}

Latest revision as of 18:34, 30 January 2021


[edit]

Guile-Gnome

https://www.gnu.org/software/guile-gnome/
Helps Scheme programmers develop visual applications.

Guile-Gnome is a Guile wrapper collection for some of the GNOME core libraries.

This package tries to build the following wrappers: Gobject, Glib, Atk, Pango, Pangocairo, Gdk, Gdk-Pixbuf, Gtk, Libglade, Libgnome, Libgnomeui, Libgnomecanvas.

Guile-Gnome makes GNOME accesible from Guile, so it provides a convenient interface for Scheme programmers to develop visual applications.





Licensing

License

Verified by

Verified on

Notes

Verified by

Janet Casey

Verified on

13 February 2004




Leaders and contributors

Contact(s)Role
David Pirotte Co-Maintainer
Andy Wingo Maintainer


Resources and communication

AudienceResource typeURI
WikidataGeneralhttps://www.wikidata.org/wiki/Q105124253
DebianDeveloperhttps://tracker.debian.org/pkg/guile-gnome-platform
Mailing Listhttps://lists.gnu.org/mailman/listinfo/guile-gtk-general/
SavannahDeveloperhttps://savannah.gnu.org/projects/guile-gnome/
FTPMailing Listhttps://ftpmirror.gnu.org/guile-gnome/
FTPDownloadhttps://ftp.gnu.org/gnu/guile-gnome/
VCS Repository Webviewhttps://git.savannah.gnu.org/cgit/guile-gnome.git/


Software prerequisites

KindDescription
Required to usegthread -2.0
Required to useCorba [(and libbonobo -2.0 Orbit -2.0)]
Required to usegdk -2.0 >= 2.10.0
Required to uselibgnome -2.0 >= 2.16
Required to uselibglade -2.0 >= 2.6
Required to usegnome-vfs -2.0 >= 2.16.0
Required to buildAutomake >= 1.12
Required to useAtk >= 1.12
Required to usegdk-pixbuf -2.0 >= 2.10.0
Required to usepango >= 1.14
Required to useobject -2.0
Required to useglib -2.0 >= 2.10.0
Required to useGuile -2.0 or Guile-2.2
Required to uselibgnomecanvas -2.0 >= 2.14
Required to usegconf -2.0 >= 2.18
Required to usegtk+ -2.0 >= 2.10.0
Source requirementGuile-Lib >= 0.2.2
Source requirementG-Wrap >= 1.9.15
Required to buildAutoconf >= 2.61
Source requirementGuile-Cairo >= 1.10
Required to usepangocairo >= 1.14
Required to uselibgnomeui -2.0 >= 2.16.0




Entry























































"Co-Maintainer" is not in the list (Maintainer, Contributor, Developer, Sponsor, Unknown) of allowed values for the "Role" property.


"Savannah" is not in the list (General, Help, Bug Tracking, Support, Developer) of allowed values for the "Resource audience" property.






"FTP" is not in the list (General, Help, Bug Tracking, Support, Developer) of allowed values for the "Resource audience" property.


"FTP" is not in the list (General, Help, Bug Tracking, Support, Developer) of allowed values for the "Resource audience" property.


"Wikidata" is not in the list (General, Help, Bug Tracking, Support, Developer) of allowed values for the "Resource audience" property.


"Debian" is not in the list (General, Help, Bug Tracking, Support, Developer) of allowed values for the "Resource audience" property.







Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.