Difference between revisions of "Mod ruby"

From Free Software Directory
Jump to: navigation, search
(Created page with "{{Entry |Name=mod_ruby |Short description=Embeds the Ruby interpreter into Apache |Full description=mod_ruby' embeds the Ruby interpreter into the Apache Web server, allowing Rub...")
 
(New version)
 
Line 3: Line 3:
 
|Short description=Embeds the Ruby interpreter into Apache
 
|Short description=Embeds the Ruby interpreter into Apache
 
|Full description=mod_ruby' embeds the Ruby interpreter into the Apache Web server, allowing Ruby CGI scripts to be executed natively. These scripts will start up much faster than without mod_ruby.
 
|Full description=mod_ruby' embeds the Ruby interpreter into the Apache Web server, allowing Ruby CGI scripts to be executed natively. These scripts will start up much faster than without mod_ruby.
 +
|Homepage URL=https://github.com/shugo/mod_ruby
 
|User level=none
 
|User level=none
|Status=Live
 
|Component programs=
 
|Homepage URL=http://www.modruby.net/
 
 
|VCS checkout command=svn co http://svn.modruby.net/repos/mod_ruby/trunk mod_ruby
 
|VCS checkout command=svn co http://svn.modruby.net/repos/mod_ruby/trunk mod_ruby
 
|Computer languages=C
 
|Computer languages=C
 
|Documentation note=User referencemanual available in HTML format from http://modruby.net/en/index.rbx/mod_ruby/classes.html
 
|Documentation note=User referencemanual available in HTML format from http://modruby.net/en/index.rbx/mod_ruby/classes.html
|Paid support=
 
|IRC help=
 
|IRC general=
 
|IRC development=
 
 
|Related projects=Ruby-LDAP
 
|Related projects=Ruby-LDAP
 
|Keywords=script,cgi,speed,apache,interpreter,Ruby
 
|Keywords=script,cgi,speed,apache,interpreter,Ruby
|Is GNU=n
+
|Version identifier=1.3.0
|Last review by=Janet Casey
+
|Version date=2008/11/08
|Last review date=2005-04-22
+
|Version status=stable
 +
|Version download=https://github.com/shugo/mod_ruby/archive/1.3.0.tar.gz
 +
|Version comment=1.3.0 stable released 2008-11-08
 +
|Last review by=Alejandroindependiente
 +
|Last review date=2017/02/13
 
|Submitted by=Database conversion
 
|Submitted by=Database conversion
 
|Submitted date=2011-04-01
 
|Submitted date=2011-04-01
|Version identifier=1.2.3
+
|Status=
|Version date=2004-09-27
+
|Is GNU=No
|Version status=stable
+
|License verified date=2004-08-25
|Version download=http://modruby.net/archive/mod_ruby-1.2.3.tar.gz
+
}}
 +
{{Project license
 +
|License=BSD_2Clause
 +
|License verified by=Janet Casey
 
|License verified date=2004-08-25
 
|License verified date=2004-08-25
|Version comment=1.2.3 stable released 2004-09-27
 
 
}}
 
}}
 
{{Person
 
{{Person
 +
|Real name=Shugo Maeda
 
|Role=Maintainer
 
|Role=Maintainer
|Real name=Shugo Maeda
 
 
|Email=shugo@ruby-lang.org
 
|Email=shugo@ruby-lang.org
 
|Resource URL=
 
|Resource URL=
Line 49: Line 49:
 
|Software-development=programming-language
 
|Software-development=programming-language
 
|Use=software-development
 
|Use=software-development
}}
 
{{Project license
 
|License=BSD_2Clause
 
|License verified by=Janet Casey
 
|License verified date=2004-08-25
 
 
}}
 
}}
 
{{Software prerequisite
 
{{Software prerequisite
Line 63: Line 58:
 
|Prerequisite description=Ruby 1.6.x or later (author recommends 1.6.4 or later)
 
|Prerequisite description=Ruby 1.6.x or later (author recommends 1.6.4 or later)
 
}}
 
}}
 +
{{Featured}}

Latest revision as of 09:29, 13 February 2017


[edit]

mod_ruby

https://github.com/shugo/mod_ruby
Embeds the Ruby interpreter into Apache

mod_ruby' embeds the Ruby interpreter into the Apache Web server, allowing Ruby CGI scripts to be executed natively. These scripts will start up much faster than without mod_ruby.

Documentation

User referencemanual available in HTML format from http://modruby.net/en/index.rbx/mod_ruby/classes.html

Related Projects





Licensing

License

Verified by

Verified on

Notes

Verified by

Janet Casey

Verified on

25 August 2004




Leaders and contributors

Contact(s)Role
Shugo Maeda Maintainer


Resources and communication

AudienceResource typeURI
DeveloperVCS Repository Webviewhttp://svn.modruby.net/cgi-bin/viewcvs.cgi/mod_ruby/
Bug Tracking,Developer,SupportE-mailmailto:modruby@modruby.net


Software prerequisites

KindDescription
Required to useApache 1.3.3 or later
Required to useRuby 1.6.x or later (author recommends 1.6.4 or later)

This entry (in part or in whole) was last reviewed on 13 February 2017.



Version comment

1.3.0 stable released 2008-11-08


Entry

































Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.