Difference between revisions of "Unieject"

From Free Software Directory
Jump to: navigation, search
m (Blanked the page)
(Undo revision 42762 by Megalanya (talk))
 
Line 1: Line 1:
 +
{{Entry
 +
|Name=unieject
 +
|Short description=A multiplatform eject command.
 +
|Full description=This package consists of a library and a command line tool which uses that lib.
  
 +
*libunieject is a library which allows the linked software to perform automatic ejects and unmounting the filesystems for the device you want to eject.
 +
 +
*The command line tool instead is a mimic of classic [[eject]] command for GNU/Linux, which supports also the features of FreeBSD's [http://www.freshports.org/sysutils/eject/ eject] command.
 +
|Homepage URL=http://flameeyes.is-a-geek.org/projects#unieject
 +
|User level=none
 +
|VCS checkout command=git clone git://gitorious.org/unieject/unieject.git unieject
 +
|Computer languages=C,
 +
|Documentation note=See the unieject man page.
 +
 +
It hasn't a complete syntax compatibility with either GNU/Linux's or FreeBSD's ejects as they have conflicts between them, but the main options are the same.
 +
 +
It can fully replace FreeBSD's eject (in both atapi and atapicam mode), and already mime the main options of GNU/Linux's eject.
 +
|Version identifier=6
 +
|Version date=2009/06/27
 +
|Version status=stable
 +
|Version download=http://sourceforge.net/projects/unieject/files/unieject/6/unieject-6.tar.bz2
 +
|Version comment=5.3.1 released on 2006-06-23
 +
|Last review by=Genium
 +
|Last review date=2013/10/02
 +
|Submitted by=Database conversion
 +
|Submitted date=2011-04-01
 +
|Status=
 +
|Is GNU=No
 +
|License verified date=2006-05-27
 +
}}
 +
{{Project license
 +
|License=GPLv2orlater
 +
|License verified by=Ted Teah
 +
|License verified date=2006-05-27
 +
}}
 +
{{Person
 +
|Real name=Diego E. 'Flameeyes' Pettenò
 +
|Role=Maintainer
 +
|Email=flameeyes@gentoo.org
 +
|Resource URL=
 +
}}
 +
{{Resource
 +
|Resource audience=Developer,Help,Support
 +
|Resource kind=E-mail
 +
|Resource URL=mailto:flameeyes@gentoo.org
 +
}}
 +
{{Resource
 +
|Resource audience=Help
 +
|Resource kind=Homepage
 +
|Resource URL=http://sourceforge.net/news/?group_id=160386
 +
}}
 +
{{Resource
 +
|Resource audience=Bug Tracking
 +
|Resource kind=Homepage
 +
|Resource URL=http://sourceforge.net/tracker/?group_id=160386
 +
}}
 +
{{Software category}}
 +
{{Software prerequisite
 +
|Prerequisite kind=Required to use
 +
|Prerequisite description=[[libcdio]]
 +
}}
 +
{{Software prerequisite
 +
|Prerequisite kind=Required to use
 +
|Prerequisite description=glib
 +
}}
 +
{{Software prerequisite
 +
|Prerequisite kind=Required to use
 +
|Prerequisite description=libconfuse
 +
}}
 +
{{Software prerequisite
 +
|Prerequisite kind=Source requirement
 +
|Prerequisite description=git
 +
}}
 +
{{Software prerequisite
 +
|Prerequisite kind=Weak prerequisite
 +
|Prerequisite description=libxslt
 +
}}
 +
{{Software prerequisite
 +
|Prerequisite kind=Required to build
 +
|Prerequisite description=gcc
 +
}}
 +
{{Featured}}

Latest revision as of 15:11, 14 February 2017


[edit]

unieject

http://flameeyes.is-a-geek.org/projects#unieject
A multiplatform eject command.

This package consists of a library and a command line tool which uses that lib.

  • libunieject is a library which allows the linked software to perform automatic ejects and unmounting the filesystems for the device you want to eject.
  • The command line tool instead is a mimic of classic eject command for GNU/Linux, which supports also the features of FreeBSD's eject command.





Licensing

License

Verified by

Verified on

Notes

Verified by

Ted Teah

Verified on

27 May 2006




Leaders and contributors

Contact(s)Role
Diego E. 'Flameeyes' Pettenò Maintainer


Resources and communication

AudienceResource typeURI
Bug TrackingHomepagehttp://sourceforge.net/tracker/?group_id=160386
HelpHomepagehttp://sourceforge.net/news/?group_id=160386
Developer,Help,SupportE-mailmailto:flameeyes@gentoo.org


Software prerequisites

KindDescription
Required to uselibcdio
Required to uselibconfuse
Required to useglib
Required to buildgcc
Source requirementgit
Weak prerequisitelibxslt




Entry































Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.